PNG32 PNG32 PNG32 PNG32
PNG32
Forum Excel, VBA, VSTO, Exceltips, Excelhj�lp PNG32 drivs av Excelspecialisten    Logga in     English
PNG32
PNG32 PNG32
PNG32

Logga in

PNG32

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

PNG32 PNG32
PNG32 PNG32
PNG32

Excelforum

PNG32

 
ForumForumDiskussionerDiskussionerExcelExcelLänka informationLänka information
Föregående Föregående
 
Nästa Nästa
Nytt inlägg
 2009-04-01 15:15
 

Hej, jag sitter på Excel -03 och pular med ett litet problem.

Jag har ett excel dokument med ett tjugotal flikar. Dessa flikar innehåller komponenter som används till produkter, varje flik innehåller alla de komponenter som används i just den produkten.

Jag har organiserat en förstasida där jag har lagt in samtliga komponenter och gjort uträkningar som visar vad kostnaden är per styck och lite annat. Det viktiga är just att den korrekta benämningen på varje komponent samt det totala priset (med frakt och allt) finns uträknat i styck pris.

Jag ska nu länka denna förstasidan till vart och ett av de olika flikarna för att på så sätt kunna få ett korrekt pris på varje komponent och således också på slutprodukten. Men varje produktflik innehåller olika komponenter, ibland samma, ibland olika, på olika rader i förhållande till första bladet. Det finns ca 20-50 rader med komponenter på varje flik medan det på förstasidan finns 150 rader. Dessutom finns det olika många kolumner på första sidan jämfört med på de övriga flikarna då all information på förstasidan inte behövs ibland de övriga flikarna.

Det som dock ser likadant ut är benämningen på komponenten och den kolumn som heter "pris". Frågan är nu om det finns någon funktion som kan leta upp benämningen på första sidan och priset och i sin tur länka in detta till den flik där samma benämning och samma pris ska in. Ex:

Förstasidan
    A         B       C      D      E 
12.Komp1   ...      ...     25     ...
29.Komp2   ...      ...     20     ...
3.Komp3   ...      ...     15    ....
29.Komp4   ...      ....    12,5    ...
30.Komp5   ...     ..       102        ...
89.Komp6  ....     ...       83      ...

Exempelflik
      A       B      C      D       E
1.Komp1                  
2.Komp2
3.Komp3
4.Komp4
5.Komp5
6.Komp6

Jag vill således skapa en formel för att i exempelfliken kunna länka och hitta komp1 ifrån förstasidan och automatiskt sätta in priset i exempelfliken.

Hänger ni med? Är detta möjligt? Hade blivit himskans glad om det fanns ett sätt så jag slapp sitta och manuellt hitta vartenda komponent och sen länka till förstasidan alla dessa gånger. :D

 

Nytt inlägg
 2009-04-03 17:56
 

Ja, kanske om jag förstått det hela rätt. Det verkar som exempelvis en LETARAD-funktion (VLOOKUP) med en nästlad PASSA-funktion kan ta dig en bit på vägen.

exempel
=LETARAD(A1;A1:G10;PASSA("Pris";1:1;0);FALSKT)

A1 – Komponenten du letar efter
A1:G10 –Förstasidans dataområde. Komponenterna i A-kolumnen
1:1 – Förstasidans rubrikrad

 

Nytt inlägg
 2009-04-03 17:56
 

Ja, kanske om jag förstått det hela rätt. Det verkar som exempelvis en LETARAD-funktion (VLOOKUP) med en nästlad PASSA-funktion kan ta dig en bit på vägen.

exempel
=LETARAD(A1;A1:G10;PASSA("Pris";1:1;0);FALSKT)

A1 – Komponenten du letar efter
A1:G10 –Förstasidans dataområde. Komponenterna i A-kolumnen
1:1 – Förstasidans rubrikrad

 

Nytt inlägg
 2009-04-14 12:39
 

Tack för svaret. Tyvärr funkar inte formeln. Det blir fel någonstans. Har försökt pilla och dona men det blir helt enkelt inte rätt. Men tack ändå. Jag fick göra det på det tunga sättet. Nu är allt länkat iaf :D

Föregående Föregående
 
Nästa Nästa
ForumForumDiskussionerDiskussionerExcelExcelLänka informationLänka information

PNG32 PNG32
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Copyright 2013 ExcelSpecialisten XLS AB   Användarvillkor  Personliga uppgifter