PNG32 PNG32 PNG32 PNG32
PNG32
Forum Excel, VBA, VSTO, Exceltips, Excelhj�lp PNG32 drivs av Excelspecialisten    Logga in     English
PNG32
PNG32 PNG32
PNG32

Logga in

PNG32

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

PNG32 PNG32
PNG32 PNG32
PNG32

Excelforum

PNG32

 
ForumForumDiskussionerDiskussionerExcelExcelFormula - Formula -
Föregående Föregående
 
Nästa Nästa
Nytt inlägg
 2019-01-12 16:52
 

 Hej! 

Jag håller på med en excel-fil och inser att jag behöver hjälp. Har lyckats få till drop downs och färger som anpassar sig som jag vill. 

I 4 kolumner, med totalt 50 rader, har jag drop downs där alternativet OK och NOT OK finns med. I slutet av varje rad, efter dessa 4 kolumner, vill jag ha en total score-ruta där den anger OK om samtliga 4 kolumner uppfyller OK på en rad. Om det finns en NOT OK på en rad så skall det alltså bli NOT OK istället. Alla måste vara OK för att det ska få bli ett OK i slutändan. Vad skall jag lägga in för formula i total score rutan för att den skall summera och ge mig ett OK eller NOT OK? 

Dimension två av detta är att jag vill att filen också skall summera antalet OK och NOT OK på totalen. Total kan det ju max bli 50 men såklart kan antalet OK och NOT OK variera och jag vill att filen skall berätta för mig hur många det är av varje. 

Svårt att forumlera sig, men hojta om jag ska förtydliga eller ange något mer. 

Väldigt tacksam för hjälp! 

Hälsar,
Dino
 

Nytt inlägg
 2019-01-14 08:22
 
Har du använt data validering för dina dropdowns? i så fall går det bra att referera till cellerna där du har dina dropdowns.

Denna ger utfallet "OK" om cellerna a1,b1,c1,d1 är "OK".
=OM(OCH(A1="OK";B1="OK";C1="OK";D1="OK");"OK";"NOT OK")

Räkna antal med kriterier görs enkelt med Antal.om.

Denna beräknar antalet celler med "OK" i kolumn B.
=antal.om(B:B; "OK")

mvh
Christian
Föregående Föregående
 
Nästa Nästa
ForumForumDiskussionerDiskussionerExcelExcelFormula - Formula -

PNG32 PNG32
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Copyright 2013 ExcelSpecialisten XLS AB   Användarvillkor  Personliga uppgifter