PNG32 PNG32 PNG32 PNG32
PNG32
Forum Excel, VBA, VSTO, Exceltips, Excelhj�lp PNG32 drivs av Excelspecialisten    Logga in     English
PNG32
PNG32 PNG32
PNG32

Logga in

PNG32

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

PNG32 PNG32
PNG32 PNG32
PNG32

Excelforum

PNG32

 
ForumForumDiskussionerDiskussionerExcelExcelSummera alltid 15 senaste talen i en tabellSummera alltid 15 senaste talen i en tabell
Föregående Föregående
 
Nästa Nästa
Nytt inlägg
 2020-04-28 17:18
 

 Jag har ett problem som jag inte rår på. Jag har en tabell där jag lägger in hållfasthet på prover jag tar, nu vill jag räkna ut medel för de 15 sista värdena jag lagt in och att medelvärdet ändras nästa gång jag lägger in ett resultat. För att göra det ännu svårare så ligger inte resultaten efter varandra utan det kan vara ett antal "0" celler imellan..alltså tex vill jag räkna ut medelvärde på 15 prover i cellerna A1:A25 där det finns 15 värden och 10 "0" värden, när jag sen lägger till ett värde i A26 ska "översta" värdet inte räknas med utan cell A26 tar den platsen..krångligt beskrivet kanske men släng ut en tanke så tar vi det därifrån

Nytt inlägg
 2020-04-29 08:16
 

Hej hej

=MEDEL.OM(FÖRSKJUTNING(D1;ANTALV(D1:D1000)-15;;15);"<>0")

Där D1 är ditt första värde i kolumnen D, som är kolumnen du vill ta medelvärde på. Obs, funktionen fungerar endast om du inte har tomma celler, i ditt intervall, nollor är dock tillåtna. 

Mvh

Christian

 

Nytt inlägg
 2020-04-29 10:00
 
 Ändrad av anonymous  på 2020-04-29 09:02:32

En liten modifikation av C's formel om du menar Tomma celler och inte 0.

För att hitta vilken rad som har den 15:e Ej tomma cellen från slutet (startcellen):

=STÖRSTA(RAD(D:D)*(D:D<>"");15)

Sen kör du i princip Christians formel.

=MEDEL(FÖRSKJUTNING(D1;STÖRSTA(RAD(D:D)*(D:D<>"");15)-1;;1000))

Obs att den kräver minns 15 värden, annars får du felmeddelande.

Om du vill ha medel även om det bara finns 10 värden får du göra något i stil med:

=MEDEL(FÖRSKJUTNING(D1;MAX(0;STÖRSTA(RAD(D:D)*(D:D<>"");15)-1);;1000))

Nytt inlägg
 2020-04-30 10:56
 

 Fungerade nästan, när jag skrev in =MEDEL(FÖRSKJUTNING(C2;STÖRSTA(RAD(C2:C400)*(C2:C400>"0");15)-1;;1000)) så blev medelvärdet konstigt.. det den gjorde var att den summerade alla värden i rad C och delade med 400. om jag lägger in din formel så här istället =MEDEL(FÖRSKJUTNING(C1;STÖRSTA(RAD(C:C)*(C:C<>"0");15)-1;;1000)) så blir det ett referensfel

A1 23

A2 0

A3 12

A4 34

A5 0

A6 12

A7 0

osv,osv

Jag vill kunna räka ut medelvärdet på låt oss säga de tre senaste cellerna som har tal >0 alltså A3+A4+A6. sen när jag lägger in ett nytt värde >0 i A8 så ska medel räknas på A5+A5+A8 allts ska 0 raden inte räknas med alls. 

Nytt inlägg
 2020-04-30 15:32
 
 Ändrad av anonymous  på 2020-04-30 14:35:08

(C2:C400>"0") är inte samma sak som (C2:C400>0)

När du sätter citattecken runt 0:an så ber du excel att leta efter texten 0, inte talet.

Men även

=MEDEL(FÖRSKJUTNING(D2;STÖRSTA(RAD(D2:D400)*(D2:D400>0);15)-1;;1000))

Blir fel eftersom den kommer att räkna med 0:orna (det var därför Christian körde med Medel.om).  Din formel bör bli någonting i stil med:

=MEDEL.OM(FÖRSKJUTNING(D1;STÖRSTA(RAD(D:D)*(D:D<>0);15)-1;;1000);">0")

(och där skall man helt plötsligt ha citattecken runt hela villkoret ">0".  Självklart?) 

eller, Keep it simple:

=SUMMA(FÖRSKJUTNING(D1;STÖRSTA(RAD(D:D)*(D:D<>0);15)-1;;1000))/15

 

Talet 1000 är det maximala antalet rader du tror att du behöver gå ner från det 15:e sista (Alltså hur många 0:or du vill ignorera). Det borde gå med ett mbetydlig mindre tal så länge det är större än 15.

Nytt inlägg
 2020-04-30 16:49
 

 Tackar, detta fungerade så nu är helgen räddad

 

Nytt inlägg
 2020-04-30 16:49
 

 Tackar, detta fungerade så nu är helgen räddad

 

Föregående Föregående
 
Nästa Nästa
ForumForumDiskussionerDiskussionerExcelExcelSummera alltid 15 senaste talen i en tabellSummera alltid 15 senaste talen i en tabell

PNG32 PNG32
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Copyright 2013 ExcelSpecialisten XLS AB   Användarvillkor  Personliga uppgifter