PNG32 PNG32 PNG32 PNG32
PNG32
Forum Excel, VBA, VSTO, Exceltips, Excelhj�lp PNG32 drivs av Excelspecialisten    Logga in     English
PNG32
PNG32 PNG32
PNG32

Logga in

PNG32

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

PNG32 PNG32
PNG32 PNG32
PNG32

Excelforum

PNG32

 
ForumForumDiskussionerDiskussionerExcelExcelRäkna från kg till prisRäkna från kg till pris
Föregående Föregående
 
Nästa Nästa
Nytt inlägg
 2020-04-16 10:08
 
 Ändrad av Sunny  på 2020-04-16 09:09:47

 Behöver verkligen hjälp!

Har intervall på kg som ska räknas om till pris.

>1-5 kg 300 kr
5-20 kg  70 kr
21-50 kg  60 kr
50-  50 kr

 1-5 kg ska vara totalt 300 kr oavsett kilo i den intervallen men alla andra viktintervall ska gångras.

Alltså ex. 7 kg ska räknas som 7*70 för att få fram priset = 490 kr.

Har försökt själv med:

=IF(C2<=5;"300";IF(C2>=5;SUM(C2*70);IF(C2>=21;SUM(C2*60);IF(C2>=50;SUM(C2*50)))))

Men de vikter som är över 20 kg räknar fortfarande på 70 kg och inte 60 eller 50.

 

HJÄLP! Vad gör jag för fel?

 

 

Nytt inlägg
 2020-04-16 13:15
 

 Hej.

När du nästlar OM/IF så stannar excel när första villkoret är uppfyllt. Dvs om<5  är sant så körs det villkoret. Det är bara om det är falskt som den kollar nästa OM/IF. Så du kollar mindre än hela tiden. I svensk excel blir det

=OM(C2<=5;300;OM(C2<=20;C2*70;OM(C2<=50;C2*60;C2*50)))

Eller marginellt kortare: 

=OM(C2<=5;300;C2*OM(C2<=20;70;OM(C2<=50;60;50)))

 

Har du en ny excel så finns även IFS som låter dig stapla vilkor på ett enkelt sätt (lika långt, men dui slipper hålla reda på 1 miljon paranteser

=IFS(C2<=5;300;C2<=20;C2*70;C2<=50;C2*60;C2>50;C2*50)

Nytt inlägg
 2020-05-04 09:52
 

 ч !!

Föregående Föregående
 
Nästa Nästa
ForumForumDiskussionerDiskussionerExcelExcelRäkna från kg till prisRäkna från kg till pris

PNG32 PNG32
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Copyright 2013 ExcelSpecialisten XLS AB   Användarvillkor  Personliga uppgifter