PNG32 PNG32 PNG32 PNG32
PNG32
Forum Excel, VBA, VSTO, Exceltips, Excelhj�lp PNG32 drivs av Excelspecialisten    Logga in     English
PNG32
PNG32 PNG32
PNG32

Logga in

PNG32

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

PNG32 PNG32
PNG32 PNG32
PNG32

Excelforum

PNG32

 
ForumForumDiskussionerDiskussionerExcelExcelSummera med flera villkor - rader och kolumnerSummera med flera villkor - rader och kolumner
Föregående Föregående
 
Nästa Nästa
Nytt inlägg
 2020-05-11 20:53
 

Hej,

Försökte få till vad jag tyckte borde vara en enkel SUMIFS formel men verkar inte alls fungera...Följande beskriver vad jag vill göra. Först delen är data som jag sedan i den nedre delen vill summera ihop, dvs baserat på två olika regler. Tex om A och Bas ska det summeras etc.  

 

  A B C A B C
Bas 10 12 14 15 10 7
Medel 5 4 6 5 6 7
Låg 4 3 2 5 7 2
             
             
  A B C      
Bas            
Medel          
Låg            

 

Nytt inlägg
 2020-05-12 07:01
 

 Hej hej

Hade jag vart du så hade jag transponerat din data. Då hade du kunnat använda sumifs m.m.

=PRODUKTSUMMA(($A$2:$F$2=A$7)*A3:F3)

Där A2:F2 antas vara raden för bokstäverna, och A3:F3 raden med Bas.

Sätter du in formeln i första cellen jämte bas, så ska A7 motsvara cellen du har bokstaven A i. Dra därefter formeln så att den lägger sig på alla dina celler i summeringen nedanför

 

MVh

CHristian

Nytt inlägg
 2020-05-12 07:53
 

 Tack för det! Det ser onekligen ut att fungera. För att utmana detta lite till. Om min data är ostrukturerad på både rad och kolumner så skulle jag behöva söka av alla rader och kolumner som innehåller mina specifika kriterier. Exempelvis om tabellen ser ut på följande sätt:

 

  A B C A B C
Bas 10 12 14 15 10 7
Medel 5 4 6 5 6 7
Låg 4 3 2 5 7 2
Bas 5 2 3 5 2 5
             
  A B C      
Bas            
Medel            
Låg            

 

FInns det någon bra formel för detta? Här fick jag inte SUMIFS att fungera då det verkar vara svårt att kombinera villkor i rad och kolumn samtidigt i samma formel.

mvh

Niclas

Nytt inlägg
 2020-05-12 09:03
 

 Hej hej

=PRODUKTSUMMA(($B$1:$F$1=B$8)*OM($A$2:$A$5=$A9;$B$2:$F$5;FALSKT))

$B$1:$F$1 = dina bokstäver i ostrukturerad data, B$8 = A i din sammanställning

$A$2:$A$5 = dina rubrikeri ostrukturerad data. $A9 = bas i din sammanställning. 

$B$2:$F$5 = ditt dataområde(alla siffror)

Rekommenderar starkt att du ser till att strukturera datan framöver. De som kan skriva en formel som du just fick, går att räkna på en hand. 

/C

 

 

 

Nytt inlägg
 2020-05-12 09:31
 

 Stort tack för det! 

Nytt inlägg
 2020-05-12 09:31
 

 Stort tack för det! 

Föregående Föregående
 
Nästa Nästa
ForumForumDiskussionerDiskussionerExcelExcelSummera med flera villkor - rader och kolumnerSummera med flera villkor - rader och kolumner

PNG32 PNG32
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Copyright 2013 ExcelSpecialisten XLS AB   Användarvillkor  Personliga uppgifter