PNG32 PNG32 PNG32 PNG32
PNG32
Forum Excel, VBA, VSTO, Exceltips, Excelhj�lp PNG32 drivs av Excelspecialisten    Logga in     English
PNG32
PNG32 PNG32
PNG32

Logga in

PNG32

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

PNG32 PNG32
PNG32 PNG32
PNG32

Excelforum

PNG32

 
ForumForumDiskussionerDiskussionerExcelExcelReturnera tal efter olika premisserReturnera tal efter olika premisser
Föregående Föregående
 
Nästa Nästa
Nytt inlägg
 2020-01-03 09:36
 

Hej,

Jag håller på att bli tokig. Jag jobbar med upphandling och statistiken vi får ut från systemet är helt obrukbar om man inte vill ödsla 5h per rapport, det borde ta 20min. 

Jag behöver hjälp att returnera ett avtalsnummer beroende på upphandlingsnummer. 

Statistiken ser ut enligt nedan:

U-ID Avtals#
22 130
22  
22  
23 140
23  
24 150
24  
24  
25 130
26 130
26  
26  
26  
26  
27 140
27  
28 130
28  

 

Låt oss säga att jag är intresserade av upphandlingar som är kopplade till Avtalsnummer 130.

Då vill jag att någon formel ska kunna indikera typ som något av nedanstående alternativ.

Alltså Om 130 finns i Avtals# så ska samhörande U-ID (22,25,26,28) indikera detta

Alternativ 1                                   Alternativ 2

U-ID Avtals#   U-ID Avtals#  
22 130   22 130 Ja
22 130   22   Ja
22 130   22   Ja
23 140   23 140 Nej
23     23   Nej
24 150   24 150 Nej
24   Alternativt-> 24   Nej
24     24   Nej
25 130   25 130 Ja
26 130   26 130 Ja
26 130   26   Ja
26 130   26   Ja
26 130   26   Ja
26 130   26   Ja
27 140   27 140 Nej
27     27   Nej
28 130   28 130 Ja
28 130   28   Ja
         

 

Tacksam för hjälp

Fredrik

Nytt inlägg
 2020-01-03 10:49
 
 Ändrad av Christian  på 2020-01-03 12:23:01
Hej hej

Lite olika alternativ(2 3 4 går att kombinera om du vill)

1. Pivottabell. ställ dig i en cell där du har data, tryck på infoga pivottabell under fliken infoga, tryck ok.
Lägg in UID på rader och AID på värden,
Komplettera med utsnitt: Stå i din pivottabell, tryck på fliken infoga, välj utsnitt och lägg till AID. Nu kan du enkelt få fram villka UID som är kopplade till eftersökt AID.

2. Vanlig tabell: Stå i din data, tryck på ctrl + T, tryck ok. Ställ därefter in filtret för AID på det avtalsnummer du vill åt.

3. Rensa data från tomma fält: Markera först all din data tryck därefter på fliken start -> Sök och Markera -> Gå till special
-> Bocka i Tomma celler -> OK.
Därefter använder du knappen ta bort på fliken start, och väljer hela raden. Vips så vart din data rensad på allt onödigt..

4. Villkorstyrd formatering. Markera först all din data tryck därefter på fliken start -> välj villkorsstyrd formatering-> regler för cellmarkering-> lika med.
I textrutan refererar du till en cell genom att klicka på exempelvis cell a1. Tryck ok. Nu kommer dina celler färgas beroende på vad du skriver i cell A1. Skriver du 130 så blir alla celler med det värdet färgade. Detta går även att filtrera på om du laggt in filter eller en tabell.

5. Formler: Om vi antar att din data börjar i A2 så kan du skriva i C2: =OM(B2<>"";B2;C1). Dra denna nedåt tills slutet av din data. Därefter kan du i cell D2 skriva =OM(C2=$E$1;"Ja";"Nej"). Utöka även denna nedåt. Formeln kommer att ge svar på värdet du väljer att skriva i cell E1.


Mvh
Christian
Nytt inlägg
 2020-06-08 09:58
 

 Hej och tack Christian,

Jag har varit föräldraledig och började jobba idag så nu har jag försökt få till det här :)

 

Statistiken vi får ut är mer komplex än jag beskrev i mitt första inlägg. En stor del av upphandlingarna saknar avtals-ID och står därför tomma. 

Jag har gått på linjen att använda ditt alternativ 5 och då tar den bara datan från ovanstående. 

Tex ser statistiken ut såhär

 

Upphand Avtals Christians rad
22 130 130
22   130
22   130
23   130
23   130
24 150 150
24   150
24   150
25 130 130
26 130 130
26   130
26   130
26   130
26   130
27 140 140
27   140
28 130 130
28   130

Som du ser följde AID 130 med även på nr UID 23.

Finns det något smart sätt att undgå detta?

 

Fredrik

Nytt inlägg
 2020-06-10 13:20
 

 Hej hej. Jodå. Låt formeln =OM(B2<>"";B2;C1) stå kvar i C2. I C3 och nedanför skriver du istället:

=OM(B3<>"";B3;OM(A3=A2;C2))

Mvh

Christian

 

Föregående Föregående
 
Nästa Nästa
ForumForumDiskussionerDiskussionerExcelExcelReturnera tal efter olika premisserReturnera tal efter olika premisser

PNG32 PNG32
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Copyright 2013 ExcelSpecialisten XLS AB   Användarvillkor  Personliga uppgifter