PNG32 PNG32 PNG32 PNG32
PNG32
Forum Excel, VBA, VSTO, Exceltips, Excelhj�lp PNG32 drivs av Excelspecialisten    Logga in     English
PNG32
PNG32 PNG32
PNG32

Logga in

PNG32

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

PNG32 PNG32
PNG32 PNG32
PNG32

Excelforum

PNG32

 
ForumForumDiskussionerDiskussionerVBAVBASöka efter en viss formel...Söka efter en viss formel...
Föregående Föregående
 
Nästa Nästa
Nytt inlägg
 2018-12-23 14:14
 

 Hej, jag har ett stort Excelark med sammanräkningar av värden i flera kolumner. Nu skall jag ändra och ta bort sammanräkningarna. Men i stället för att manuellt leta upp formeln "=SUMMA(A1:A25)" och vidare nedåt i kolumnen med olika intervall, vill jag hitta en sökfunktion i VBA som kan hitta min formel "=SUMMA(" och sen ta bort den. Jag försöker med instr men jag får inte till det...

For I = 1 to 19000

     If Cells(I,54).HasFormula = True Then

          If Formula = "=SUMMA(" then

               Cells(I,54) = ""

               Cells(I,55) = ""

          End If

     End if

Next I

Nytt inlägg
 2018-12-25 22:53
 

 En chansning men testa att ersätta raden

If Formula ="=SUMMA(" then

med

 

If Mid(Cells(I,54).Formula,1,5)="=SUM(" then

 

 

Nytt inlägg
 2019-01-11 08:48
 
Hej hej

Om du inte fått till det så är det absolut smidigaste att använda sök/ersätt. Markera kolumn(er) använd tryck sök/ersätt -> avancerat ->

Sök: =summa alternativt =summa*
Ersätt: ""

Se till att söka på blad/formler och att "Matcha hela cellinnehållet" är urbockat

Annars så fungerar instr metoden såhär:

If InStr(1, Cells(i, 54).FormulaLocal, "SUMMA", 1) > 0 then

Börjes metod fungerar den med eftersom .formula ger den engelska motsvarigheten till =summa.

/c


Föregående Föregående
 
Nästa Nästa
ForumForumDiskussionerDiskussionerVBAVBASöka efter en viss formel...Söka efter en viss formel...

PNG32 PNG32
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Copyright 2013 ExcelSpecialisten XLS AB   Användarvillkor  Personliga uppgifter